Scheduled Maintenance Extended by: 0:30 Hrs Application will be available by : 09:00 AM UTC
The scheduled maintenance is taking longer than anticipated as our team works to ensure the best possible enhancements. We apologize for any inconvenience caused by the extended duration. We appreciate your patience and will provide updates as soon as the maintenance is completed. Thank you for your understanding.
Posted Jul 01, 2025 - 08:24 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2025 - 05:30 UTC
Scheduled
We will be performing planned maintenance on our iConnectYou and Balancy applications to implement important enhancements and optimize our systems. During this time, there might be temporary disruptions in the service. We apologize for any inconvenience caused and appreciate your understanding. The maintenance window is scheduled as follows:
Date: 01-July-2025 Start Time: 05:30 AM UTC End Time: 08:30 AM UTC
Posted Jun 23, 2025 - 16:05 UTC
This scheduled maintenance affected: Mobile Applications (Balancy, IConnectYou ( Mobile App ), Online Scheduler (iConnectYou), IConnectYou APIs) and Member Website (Online Scheduler (Member Website)).